Muy buenas,

Hoy, con ganas de comenzar a ver algunas mejoras de Windows Azure SDK 1.5, parto con la puesta en marcha del entorno y para ello:

  1. Instalar“WindowsAzureToolsVS2010.exe” (Web Installer ) y que en esta versión (todo en uno), incluye tanto el SDK 1.5 como las Tools para Visual Studio 2010.
  2. Seguidamente el Windows Azure AppFabric  1.5  que podéis descargar desde aquí.
  3. Al arrancar en modo debug (F5) la aplicación con un proyecto de Azure

image

Se genera la BBDD “DevelopmentStorageDb20110816” necesaria para la simulación de Windows Azure en local  y todo parece ir bien, perooo, zaaaas, error del Storage Emulator (Alguna vez ya sucedió, pero esta vez se está haciendo de rogar, así que da lugar a un post, Risa).

image

Concretamente el error es:

There is already a listener on IP endpoint 127.0.0.1:12001.  Make sure that you are not trying to use this endpoint multiple times in your application and that there are no other applications listening on this endpoint.

Desde la línea de comando ejecutamos el siguiente comando:

   1: netstat /a /b

Y vemos que, efectivamente un proceso esta ocupando el puerto 12001.

image

Si se matamos el proceso, a veces, se auto-arranca, así que, o “dejamos de usar VMWARE (Cosa que debería hacer)” o bien:

No cambiemos nada en el fichero “C:\Program Files\Windows Azure SDK\v1.5\bin\devstore\DSService.exe.config” para ver la configuración del “Windows Storage Emulator” puesto que obtendrás errores del tipo “The process cannot access the file because it is being used by another process”:

image

Por el momento con matar el servicio ha funcionado, pero aun así, me encuentro con este otro error: “Role instances are taking longer than expected to start” (grrr…. vaya día….):

image

Estos son los Know Issues detectados en Windows Azure SDK 1.5 hasta el momento:

  1. Incomplete Windows Azure Blob Download using DownloadToStream, DownloadToFile, DownloadText, and DownloadByteArray methods
  2. Windows Azure SDK 1.5 Compute Emulator Fails to Start
  3. Windows Azure SDK 1.5 Compute Emulator Listen Port Unavailable
  4. IIS7 Logs Are Not Collected Properly

Como nota principal: No debería estar ocupado ninguno de los puertos: 12000, 12001, 12002, 808, 16001, o 15100.

Reviso el “Compute Emulator UI” donde el estado de mi Web Role es “Role State Unknow”.

Finalmente, tras revisar todo nuevamente paso a paso; los diferentes Logs que genera el storage emulador, varios reinicios del visual estudio, deshabilitar los diagnósticos de Windows Azure de mi proyecto, etc, es que el maldito puerto “808” pertenece a los bindings del “Default Web Site” en el IIS.

image

Los eliminamos y después de tantas vueltas, todo queda funcionando correctamente.

Ahora a celebrarlo con unas birras y una buena cena, ¡que es sabadete! Risa.

Espero que a mas de uno le evite una pesadilla !!!

Buen fin de semana a tod@s

Juanlu, ElGuerre